Which phones work with Kinsa thermometers?

The wireless Kinsa QuickCare and Kinsa Smart Ear thermometers are compatible with any modern smartphone which can run the Kinsa app. The Kinsa app is needed to enable smart features.

The wired Kinsa Smart Stick thermometer must be connected with its own Kinsa Smart Stick app to take temperature readings. But since the wired Smart Stick thermometer has been discontinued, it is compatible with far fewer smartphones.

 

Minimum requirements

The Kinsa app is free for iPhones and Android phones and requires at least iOS 11 or Android 5.

The Kinsa Smart Stick app is also free for iPhone and Android phones and also requires iOS 11 or Android 5.

 

  

Phone Compatibility

Find your thermometer on the table below and click iPhone or Android to view the compatible smartphones.

 

QuickCare

QuickCare

iPhone Android

Smart Ear

Smart Ear

iPhone Android

Smart Stick

Smart Stick

(discontinued)

iPhone Android

 

 

 

QuickCare and iPhone

iPhone Status
iPhone 11
iPhone 11 Pro
iPhone 11 Pro Max
iPhone XS
iPhone XS Max
iPhone XR
iPhone X
iPhone 8
iPhone 8 Plus
iPhone 7
iPhone 7 Plus
iPhone 6S
iPhone 6S Plus
iPhone 6
iPhone 6 Plus
iPhone SE
iPhone 5s
iPhone 5c
iPhone 5
iPhone 4s
iPhone 4

 

QuickCare and Android

Compatible with any Android phone running Android 5.0 or above. Leading android phones listed below:

Android Phone Status
Samsung Note 8
Samsung Note 5
Samsung Note 4
Samsung Note 3
Samsung Note 2
Samsung Galaxy S9
Samsung Galaxy S9+
Samsung Galaxy S8
Samsung Galaxy S8+
Samsung Galaxy S7
Samsung Galaxy S7 Active
Samsung Galaxy S7 Edge
Samsung Galaxy S6
Samsung Galaxy S6 Active
Samsung Galaxy S6 Edge
Samsung Galaxy S6 Edge+
Samsung Galaxy S5
Samsung Galaxy S5 Active
Samsung Galaxy S4
Samsung Galaxy S4 Active
Samsung Galaxy S3
Google Pixel 3
Google Pixel 3 XL
Google Pixel 3a
Google Pixel 3a XL
Google Pixel 2
Google Pixel XL
Google Pixel
Google Pixel XL
Nexus 6
Nexus 6P
Nexus 5X
HTC 10
HTC One M9
HTC One M8
LG G6
LG G5
LG G4
LG G3
Moto G4
Moto X

 

Smart Ear and iPhone

iPhone Status
iPhone 11
iPhone 11 Pro
iPhone 11 Pro Max
iPhone XS
iPhone XS Max
iPhone XR
iPhone X
iPhone 8
iPhone 8 Plus
iPhone 7
iPhone 7 Plus
iPhone 6S
iPhone 6S Plus
iPhone 6
iPhone 6 Plus
iPhone SE
iPhone 5s
iPhone 5c
iPhone 5
iPhone 4s
iPhone 4

 

Smart Ear and Android

Android Phone Status
Samsung Note 8
Samsung Note 5
Samsung Note 4
Samsung Note 3
Samsung Note 2
Samsung Galaxy S9
Samsung Galaxy S9+
Samsung Galaxy S8
Samsung Galaxy S8+
Samsung Galaxy S7
Samsung Galaxy S7 Active
Samsung Galaxy S7 Edge
Samsung Galaxy S6
Samsung Galaxy S6 Active
Samsung Galaxy S6 Edge
Samsung Galaxy S6 Edge+
Samsung Galaxy S5
Samsung Galaxy S5 Active
Samsung Galaxy S4
Samsung Galaxy S4 Active
Samsung Galaxy S3
Google Pixel 3
Google Pixel 3 XL
Google Pixel 3a
Google Pixel 3a XL
Google Pixel 2
Google Pixel XL
Google Pixel
Google Pixel XL
Nexus 6
Nexus 6P
Nexus 5X
HTC 10
HTC One M9
HTC One M8
LG G6
LG G5
LG G4
LG G3
Moto G4
Moto X

 

Smart Stick and iPhone

Note: The Kinsa Smart Stick is now discontinued. This table will not receive further updates.

iPhone Status
iPhone 11 ⚠️ Detail
iPhone 11 Pro ⚠️ Detail
iPhone 11 Pro Max ⚠️ Detail
iPhone XS ⚠️ Detail
iPhone XS Max ⚠️ Detail
iPhone XR ⚠️ Detail
iPhone X ⚠️ Detail
iPhone 8 ⚠️ Detail
iPhone 8 Plus ⚠️ Detail
iPhone 7 ⚠️ Detail
iPhone 7 Plus ⚠️ Detail
iPhone 6S
iPhone 6S Plus
iPhone 6
iPhone 6 Plus
iPhone SE
iPhone 5s
iPhone 5c
iPhone 5
iPhone 4s
iPhone 4

 

Smart Stick and Android

Note: The Kinsa Smart Stick has now been discontinued. The table below will not receive further updates.

If your phone is newer than the models listed below, your new phone is probably not compatible.

Beginning with Android 7.0, (aka Nougat) this OS version changed the way audio signals are handled by the phone. This change blocks the Smart Stick's signals from reaching the Kinsa app. Because this change comes from the underlying Android operating system, we could not fix this through the Kinsa app.

If you have upgraded to a new phone which is not compatible, sadly this cannot be fixed due to the underlying changes to the Android operating system. 

We've learned a lot in the many years since we first launched the Smart Stick, which is why we built our new Kinsa QuickCare to be our most compatible thermometer ever.

Thanks to its wireless capabilities, the Kinsa QuickCare is backwards and forwards compatible with all phones that can run the Kinsa app, including every phone listed below. 

If you would like to learn more about or upgrade to the Kinsa QuickCare, they're available for sale here.

 

Android Phone Status
Samsung Note 8
Samsung Note 5 ⚠️ Detail
Samsung Note 4
Samsung Note 3
Samsung Note 2
Samsung Galaxy S10
Samsung Galaxy S9
Samsung Galaxy S9+
Samsung Galaxy S8
Samsung Galaxy S8+ ❌ 
Samsung Galaxy S7 ⚠️ Detail
Samsung Galaxy S7 Active ⚠️ Detail
Samsung Galaxy S7 Edge ⚠️ Detail
Samsung Galaxy S6 ⚠️ Detail
Samsung Galaxy S6 Active ⚠️ Detail
Samsung Galaxy S6 Edge ⚠️ Detail
Samsung Galaxy S6 Edge+ ⚠️ Detail
Samsung Galaxy S5
Samsung Galaxy S5 Active
Samsung Galaxy S4
Samsung Galaxy S4 Active
Samsung Galaxy S3
Google Pixel 3
Google Pixel 3 XL
Google Pixel 3a
Google Pixel 3a XL
Google Pixel 2
Google Pixel XL
Google Pixel
Google Pixel XL
Nexus 6
Nexus 6P
Nexus 5X
HTC 10
HTC One M9
HTC One M8
LG G6 ⚠️ Detail
LG G5 ⚠️ Detail
LG G4 ⚠️ Detail
LG G3
Moto G4
Moto X
Alcatel OneTouch

 

⚠️ Exceptions

iPhone 7 and later iPhone models + Smart Stick

The Smart Stick can still work, but special steps are needed since there are no built-in headphone jacks in these phones. Follow this guide.

Samsung Galaxy S8, Note 8, Note 5 + Smart Stick

Android 7.0 (aka Nougat) and later updates break compatibility with the Smart Stick. These phones are not compatible with the Smart Stick after Android 7.0 or later updates have been installed. 

Samsung Galaxy S7 and S6 (All Variants) + Smart Stick

Fully compatible with Android 6.0.1 or earlier.

Android 7.0 (aka Nougat) and later updates break compatibility with the Smart Stick. These phones are not compatible with the Smart Stick after Android 7.0 or later updates have been installed. 

HTC One M8 or HTC One M9 + Smart Stick or Smart Ear

Requires Android 5.0.1 (aka “Lollipop") or later to be installed.

LG G6 + Smart Stick

Android 7.0 (aka Nougat) and later updates break compatibility with the Smart Stick. This phone is not compatible with the Smart Stick after Android 7.0 or later updates have been installed. 

LG G4 or LG G5 + Smart Stick or Smart Ear

Requires Android 6.0 (aka “Marshmallow"). Android 7.0 (aka Nougat) and later updates break compatibility with the Smart Stick once installed.

LG G3 + Smart Stick or Smart Ear

Requires Android 5.0.1 (aka “Lollipop") or later.

Nexus 5X + Smart Stick

Requires Android 7.1.2 or later only.

362 out of 605 found this helpful